Domain is not created in PSA upon domain order provisioning

Article ID: 5231 
Last Review: Oct,6 2008
Author:
Last updated by: system APPLIES TO:
  • Parallels Business Automation - Enterprise, 4.1
  • Parallels Business Automation - Enterprise, 4.2

Symptoms

Domain is not created in PSA upon successful domain registration.

Cause

Domain registration cycle in PBA depends on domain service template configuration. If domain service template is configured to acquire name servers from PSA, the last step of the cycle is creating domain in PSA. If domain service template has name server set explicitly,  the domain is not created in PSA.

Resolution

To resolve the issue for particular domain:
  1. Log in to PSA CP under customer.
  2. Open the Domain Overview > Domain Admintration submenu of the Navigation menu.
  3. Click Add existing domain registered elsewhere. The adding new domain wizard starts.
  4. Input full domain name into the Domain field. Change Zone management ability and Mail Hosting settings if necessary.
  5. Click Next >> to proceed to the next step. Verify the information and click Finish if everything is intact.
  6. Log in to PSA under vendor.
  7. Open the Operations Director > Domain Manager > Domains submenu of the Navigation tree.
  8. Enter the domain added from customer CP.
  9. Click Edit.
  10. Change the Registrar Status to Ready.
  11. Click Save to confirm changes.
Domain subscription for domain configured that way can be renewed, cancelled, etc. in general way as any other domain subscription.

System behaviour for new domain registrations / transfers can be adjusted as described below.

ATTENTION!
  1. Auiring name servers from PSA requires PSA hosting template to include resource DNS hosting. Make sure that this resource is present in hosting service template if domain is purchased with hosting, or in default DNS template if domain is purchased without hosting.
  2. Name servers can be auired from PSA only if one pair is configured. If you plan to use two pairs of name servers (i.e. NS1+NS2 and NS3+NS4), name servers have to be set in  domain service template explicitly.
To change system behaviour on permanent basis:
  1. Log in to PBA CP under vendor.
  2. Open the Product Director > Plan Manager > Service Template submenu of the Navigation tree.
  3. Enter desired domain service templae properties.
  4. Click Edit.
  5. Select  Acquire Automatically option from Name Servers group.
  6. Click [...] button and select PEM DNS Controller from the list that opens.
  7. Click Save to confirm changes.


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